Welcome, Guest
Username Password: Remember me

Switching back and forth between mobile & desktop version
(1 viewing) (1) Guest
  • Page:
  • 1

TOPIC: Switching back and forth between mobile & desktop version

Switching back and forth between mobile & desktop version 10 years, 2 months ago #8181

  • pvandoorn
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
Imagine you have a visitor on your mobile website. Always good, right? But suddenly, he decides he wants to view the standard 'normal' version of the website. He scrolls down to the bottom, and clicks the link 'standard'. No problems so far. But when this visitor clicks on any links on that page, that link is suddenly displayed in the mobile template again! Why is that? It's as if the preference "device=desktop" isn't stored. Is this a bug, or a setting I just can't seem to locate?

Re: Switching back and forth between mobile & desktop version 10 years, 2 months ago #8259

  • dryabov
  • OFFLINE
  • Administrator
  • Denis Ryabov, Lead Developer
  • Posts: 4851
  • Karma: 105
MJ stores current "mode" in cookies, so it should work. What is URL of your site and what device do you use to test?

Re: Switching back and forth between mobile & desktop version 10 years, 2 months ago #8291

  • pvandoorn
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
That might explain why I haven't been getting the problem on some of my other mobile sites.

www.betronic.nl

I've used an iPhone, blackberry and htc for testing. I'll test all of them again, as soon as I can, and check whether or not they disabled cookies. Or I don't think they did...

Re: Switching back and forth between mobile & desktop version 10 years, 2 months ago #8293

  • dryabov
  • OFFLINE
  • Administrator
  • Denis Ryabov, Lead Developer
  • Posts: 4851
  • Karma: 105
OK, I see the problem on your site. Disable "Mobile-Domains" plugin to fix it.
The following user(s) said Thank You: pvandoorn

Re: Switching back and forth between mobile & desktop version 10 years, 2 months ago #8294

  • pvandoorn
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
That fixed it! Thank you so much!

I've checked this plugin on a few of my other mobile websites, and they don't seem to have it yet. Am I correct in assuming this plugin was added in the latest Mobile Joomla! version? It would explain why I didn't have the problem before. Either way, thanks! I'll be sure to disable this plugin from now on . Unless it's supposed to do something important? What is this plugin supposed to do?

Sorry, I misread. They do have the plugin. It's weird. I really don't recall having this problem before, but if it's been in the component for a while, and if it's enabled by default... why did it suddenly stop working properly?
Last Edit: 10 years, 2 months ago by pvandoorn.
  • Page:
  • 1
Time to create page: 0.06 seconds

By continuing to use this site you consent to the use of cookies on your device as described in our cookie policy unless you have disabled them. This site will not function correctly without cookies.

I accept cookies from this site.