Welcome, Guest
Username Password: Remember me

Mobile Joomla not working
(1 viewing) (1) Guest
  • Page:
  • 1
  • 2

TOPIC: Mobile Joomla not working

Mobile Joomla not working 10 years, 8 months ago #5354

  • tedm
  • OFFLINE
  • Fresh Boarder
  • Posts: 2
  • Karma: 0
I installed 1.0-RC3 on my J1.5 site. The install completed successfully. I have an iPhone template which worked fine on 1.0-RC2.1 but now my iPhone displays only the 'standard' website. I tried un-installing RC3 and re-installing RC2.1 but the problem is the same. If I add "?device=iphone" to the URL the iPhone template comes up but this is useless. What am I missing ???? Thanks.
Last Edit: 10 years, 8 months ago by tedm.

Re: Mobile Joomla not working 10 years, 8 months ago #5358

  • dryabov
  • OFFLINE
  • Administrator
  • Denis Ryabov, Lead Developer
  • Posts: 4851
  • Karma: 105
Note that MJ saves last mobile mode chosen in browser, so once you click on standard version your browser starts to display standard version until you choose another mode (by click on corresponding link or adding ?device= parameter). Just tested mobilejoomla.com and it works well with iphone.
The following user(s) said Thank You: tedm

Re: Mobile Joomla not working 10 years, 8 months ago #5369

  • myusername
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
I am having the very same issue . . . auto redirect not working since update

I think there is an issue here

I have tried it on a number of devices and simulators

Re: Mobile Joomla not working 10 years, 8 months ago #5370

  • dryabov
  • OFFLINE
  • Administrator
  • Denis Ryabov, Lead Developer
  • Posts: 4851
  • Karma: 105
What is url of your site?

Re: Mobile Joomla not working 10 years, 8 months ago #5371

  • myusername
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
Thanks for the fast reply

enniscroneonline.com

Re: Mobile Joomla not working 10 years, 8 months ago #5372

  • myusername
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
just used another old phone with opera browser that would have never visted site and that redirected ok

does JM drop a cookie on user end - - is that how JM notes what version to load?

Re: Mobile Joomla not working 10 years, 8 months ago #5373

  • dryabov
  • OFFLINE
  • Administrator
  • Denis Ryabov, Lead Developer
  • Posts: 4851
  • Karma: 105
myusername wrote:
does JM drop a cookie on user end - - is that how JM notes what version to load?

Yes, MJ saves current mobile version in cookies for 365 days.
The following user(s) said Thank You: tedm

Re: Mobile Joomla not working 10 years, 8 months ago #5384

  • tedm
  • OFFLINE
  • Fresh Boarder
  • Posts: 2
  • Karma: 0
dryabov wrote:
Note that MJ saves last mobile mode chosen in browser, so once you click on standard version your browser starts to display standard version until you choose another mode (by click on corresponding link or adding ?device= parameter). Just tested mobilejoomla.com and it works well with iphone.

The above and the 'cookie' comment below explains a great deal of the behavour I've been seeing. Many thanks Dryabov. Just one problem remains for me. Whereas sitename.com works fine for me (testing on iPhone 4), if I enter the www version, i.e. www.sitename.com MJ does not work. I've forced it with the device=iphone parameter (which works) to see if it was a cookie issue but when I return to www.sitename.com I'm still getting the standard version on my iPhone.
Thanks again.

POSTSCRIPT: I've solved this. It WAS the cookies; I cleared the cookies on the iPhone (Settings->Safari->Clear Cookies) and this solved the problem. Thanks.
Last Edit: 10 years, 8 months ago by tedm.

Re: Mobile Joomla not working 10 years, 8 months ago #5386

  • dryabov
  • OFFLINE
  • Administrator
  • Denis Ryabov, Lead Developer
  • Posts: 4851
  • Karma: 105
It's because of cookies are domain-dependent (by default) and sitename.com and www.sitename.com are different domains (actually, there is a way to set cookies that are common for domain and all its subdomains, but MJ doesn't use this way).

Re: Mobile Joomla not working 10 years, 2 months ago #7892

  • belsis
  • OFFLINE
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
Hello all i had the same issue i had a site working fine with 0.9 then i received an email about stability and security update i installed the site only works without mobile. when i log on at the administrator it shows COM_MJ_UPDATE_AVAILABLE
  • Page:
  • 1
  • 2
Time to create page: 0.09 seconds

By continuing to use this site you consent to the use of cookies on your device as described in our cookie policy unless you have disabled them. This site will not function correctly without cookies.

I accept cookies from this site.