Welcome, Guest
Username Password: Remember me

New user - mobile detection problem
(1 viewing) (1) Guest
  • Page:
  • 1

TOPIC: New user - mobile detection problem

New user - mobile detection problem 1 month, 1 week ago #21495

  • TheBigBoo
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
Hi,
I'm trying to setup Mobile Joomla! on a website and I have it installed and it works if I visit the site with ?device=auto on the URL but not if I just visit the site.
I've tried it in a new browser, private mode, cleared cookies etc. Am I missing something basic and obvious?
Many thanks.

Re: New user - mobile detection problem 1 month, 1 week ago #21496

  • dryabov
  • OFFLINE
  • Administrator
  • Denis Ryabov, Lead Developer
  • Posts: 4766
  • Karma: 105
What is URL of your website?
Do you use a caching plugin (Joomla's System Cache or 3rdparty one)?

Re: New user - mobile detection problem 1 month, 1 week ago #21497

  • TheBigBoo
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
Hi, thanks for the quick reply!
It's hullcommunitychurch.com
The System Cache is set to off in Global Configuration. The website is behind Cloudflare.
Last Edit: 1 month, 1 week ago by TheBigBoo.

Re: New user - mobile detection problem 1 month, 1 week ago #21498

  • dryabov
  • OFFLINE
  • Administrator
  • Denis Ryabov, Lead Developer
  • Posts: 4766
  • Karma: 105
I guess it is a result of aggressive caching by CloudFlare, because on some device I got mobile version, and on others I got desktop version, but after clearing cookies and reloading page it switched to mobile version.

Could you send me ( This e-mail address is being protected from spambots. You need JavaScript enabled to view it ) a list of CloudFlare's Speed and Caching settings you have enabled for your website? I'll try to reproduce it on a test website and found which one is responsive for incorrect behaviour.

Re: New user - mobile detection problem 1 month, 1 week ago #21499

  • dryabov
  • OFFLINE
  • Administrator
  • Denis Ryabov, Lead Developer
  • Posts: 4766
  • Karma: 105
Also you may try to set "Vary header" settings in the Mobile's Advanced settings. If CloudFlare takes it into account, mobile version of page shold be cached separately of desktop version.

Re: New user - mobile detection problem 1 month, 1 week ago #21500

  • TheBigBoo
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
Thanks for the information.
The "Vary header" setting didn't work but the cache settings on Cloudflare did.
The cache on Cloudflare was set to 15 days! Once that was switched off it started working straight away.
Thanks for all your help.
  • Page:
  • 1
Time to create page: 0.10 seconds

By continuing to use this site you consent to the use of cookies on your device as described in our cookie policy unless you have disabled them. This site will not function correctly without cookies.

I accept cookies from this site.